2016年09月02日

OpenBSD 6.0 自作パッケージソース

9月1日付けで OpenBSD 6.0 がリリースされました。

バージョンが古いパッケージがあるので、自作パッケージソースを一通り更新しました。なお、標準パッケージが既に最新バージョンになっているものは抜いてあります。

無保証ですので自己責任で。

/usr/ports/net/avahi-0.6.32
avahi-0.6.32.pkgsrc.tgz

/usr/ports/security/clamav-0.99.2
clamav-0.99.2p0.pkgsrc.tgz

/usr/ports/www/emacs-w3m-20160825
emacs-w3m-20160825.pkgsrc.tgz

/usr/ports/devel/gettext-0.19.8.1
gettext-0.19.8.1.pkgsrc.tgz

/usr/ports/devel/gettext-tools-0.19.8.1
gettext-tools-0.19.8.1.pkgsrc.tgz

/usr/ports/security/gnupg-1.4.21
gnupg-1.4.21.pkgsrc.tgz

/usr/ports/security/gnupg2-2.1.15
gnupg2-2.1.15.pkgsrc.tgz

/usr/ports/mail/im
im-151.pkgsrc.tgz

/usr/ports/japanese/nkf-2.1.4
ja-nkf-2.1.4v0.pkgsrc.tgz

/usr/ports/japanese/kakasi-2.3.6
kakasi-2.3.6.pkgsrc.tgz

/usr/ports/security/libassuan-2.4.3
libassuan-2.4.3.pkgsrc.tgz

/usr/ports/security/libgcrypt-1.7.3
libgcrypt-1.7.3.pkgsrc.tgz

/usr/ports/security/libgpg-error-1.24
libgpg-error-1.24.pkgsrc.tgz

/usr/ports/converters/libiconv-1.14ja
libiconv-1.14p3ja.pkgsrc.tgz

/usr/ports/devel/libidn-1.33
libidn-1.33.pkgsrc.tgz

/usr/ports/security/libksba-1.3.5
libksba-1.3.5.pkgsrc.tgz

/usr/ports/security/libtasn1-4.9
libtasn1-4.9.pkgsrc.tgz

/usr/ports/textproc/lv
lv-4.51.pkgsrc.tgz

/usr/ports/mail/mailcrypt-3.5.9
mailcrypt-3.5.9.pkgsrc.tgz

/usr/ports/mail/mew-6.7
mew-6.7p1.pkgsrc.tgz

/usr/ports/graphics/openjpeg-1.5.2
openjpeg-1.5.2.pkgsrc.tgz

/usr/ports/devel/pcre-8.39
pcre-8.39.pkgsrc.tgz

/usr/ports/security/pinentry-0.9.7
pinentry-0.9.7.pkgsrc.tgz

/usr/ports/graphics/png-1.6.25
png-1.6.25.pkgsrc.tgz

/usr/ports/security/stunnel-5.35
stunnel-5.35.pkgsrc.tgz

/usr/ports/multimedia/swftools-0.9.2
swftools-0.9.2.pkgsrc.tgz

上記でリンクしている *.pkgsrc.tgz をダウンロードし、上記のディレクトリ配置になるように展開して、そのディレクトリ内で
make package
と実行すれば /usr/ports/packages/`uname -m`/all/ 以下にそれぞれ

avahi-0.6.32.tgz
clamav-0.99.2p0.tgz
emacs-w3m-20160825.tgz
gettext-0.19.8.1.tgz
gettext-tools-0.19.8.1.tgz
gnupg-1.4.21.tgz
gnupg-2.1.15.tgz
im-151.tgz
ja-nkf-2.1.4v0.tgz
kakasi-2.3.6.tgz
libassuan-2.4.3.tgz
libgcrypt-1.7.3.tgz
libgpg-error-1.24.tgz
libiconv-1.14p3ja.tgz
libidn-1.33.tgz
libksba-1.3.5.tgz
libtasn1-4.9.tgz
lv-4.51.tgz
mailcrypt-3.5.9-gnupg.tgz
mew-6.7p1.tgz
openjpeg-1.5.2.tgz
pcre-8.39.tgz
pinentry-0.9.7.tgz
png-1.6.25.tgz
stunnel-5.35.tgz
swftools-0.9.2.tgz


というパッケージが出来ます。
posted by yamaga at 23:37| Comment(0) | TrackBack(0) | OpenBSD | このブログの読者になる | 更新情報をチェックする
この記事へのコメント
コメントを書く
お名前: [必須入力]

メールアドレス:

ホームページアドレス:

コメント: [必須入力]

認証コード: [必須入力]


※画像の中の文字を半角で入力してください。
※ブログオーナーが承認したコメントのみ表示されます。

この記事へのトラックバック